<!DOCTYPE html>
<html lang="en-US">
<head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2018823454141685" crossorigin="anonymous"></script>

<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-179324238-1"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-179324238-1');
</script>
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>Denver Nuggets and free-agent wing Bruce Brown agreed on a two-year, $13 million contract &#8211; Joplin Business Journal &#8211; Joplin Business Journal</title><link rel="stylesheet" href="https://www.joplinbusinessjournal.com/wp-content/cache/min/1/0b0efa47887465ee4ef2b330c5f042c6.css" media="all" data-minify="1" />
<meta name='robots' content='max-image-preview:large' />
<meta name="viewport" content="width=device-width, initial-scale=1"><link rel='dns-prefetch' href='//www.joplinbusinessjournal.com' />
<link rel="alternate" type="application/rss+xml" title="Joplin Business Journal &raquo; Feed" href="https://www.joplinbusinessjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Joplin Business Journal &raquo; Comments Feed" href="https://www.joplinbusinessjournal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Joplin Business Journal &raquo; Denver Nuggets and free-agent wing Bruce Brown agreed on a two-year, $13 million contract &#8211; Joplin Business Journal Comments Feed" href="https://www.joplinbusinessjournal.com/2022/07/01/denver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal/feed/" />
<link rel="alternate" type="application/rss+xml" title="Joplin Business Journal &raquo; Stories Feed" href="https://www.joplinbusinessjournal.com/web-stories/feed/"><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='global-styles-inline-css'>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</style>
<style id='generate-style-inline-css'>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</style>
<link rel="https://api.w.org/" href="https://www.joplinbusinessjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.joplinbusinessjournal.com/wp-json/wp/v2/posts/7202" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.joplinbusinessjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.joplinbusinessjournal.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0" />
<link rel="canonical" href="https://www.joplinbusinessjournal.com/2022/07/01/denver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal/" />
<link rel='shortlink' href='https://www.joplinbusinessjournal.com/?p=7202' />
<link rel="alternate" type="application/json+oembed" href="https://www.joplinbusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.joplinbusinessjournal.com%2F2022%2F07%2F01%2Fdenver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.joplinbusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.joplinbusinessjournal.com%2F2022%2F07%2F01%2Fdenver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal%2F&#038;format=xml" />
<link rel="pingback" href="https://www.joplinbusinessjournal.com/xmlrpc.php">

<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="amphtml" href="https://www.joplinbusinessjournal.com/2022/07/01/denver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal/?amp=1"><link rel="icon" href="https://www.joplinbusinessjournal.com/wp-content/uploads/2021/06/cropped-Joplin-Business-Journal-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.joplinbusinessjournal.com/wp-content/uploads/2021/06/cropped-Joplin-Business-Journal-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.joplinbusinessjournal.com/wp-content/uploads/2021/06/cropped-Joplin-Business-Journal-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.joplinbusinessjournal.com/wp-content/uploads/2021/06/cropped-Joplin-Business-Journal-icon-1-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-7202 single-format-standard wp-embed-responsive no-sidebar nav-float-right separate-containers header-aligned-left dropdown-hover featured-image-active">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <header class="site-header has-inline-mobile-toggle" id="masthead" aria-label="Site">
<div class="inside-header grid-container">
<div class="site-branding">
<p class="main-title">
<a href="https://www.joplinbusinessjournal.com/" rel="home">
Joplin Business Journal
</a>
</p>
</div> <nav class="main-navigation mobile-menu-control-wrapper" id="mobile-menu-control-wrapper" aria-label="Mobile Toggle">
<button data-nav="site-navigation" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="screen-reader-text">Menu</span> </button>
</nav>
<nav class="main-navigation sub-menu-right" id="site-navigation" aria-label="Primary">
<div class="inside-navigation grid-container">
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-header" class=" menu sf-menu"><li id="menu-item-4504" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4504"><a href="https://www.joplinbusinessjournal.com/category/news/">News</a></li>
<li id="menu-item-4508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4508"><a href="https://www.joplinbusinessjournal.com/category/crypto/">Crypto</a></li>
<li id="menu-item-4507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4507"><a href="https://www.joplinbusinessjournal.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-4506" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4506"><a href="https://www.joplinbusinessjournal.com/category/gaming/">Gaming</a></li>
<li id="menu-item-4505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4505"><a href="https://www.joplinbusinessjournal.com/category/tech/">TECH</a></li>
<li id="menu-item-6779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6779"><a href="https://www.joplinbusinessjournal.com/web-stories/">Web Stories</a></li>
<li id="menu-item-6585" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6585"><a href="https://www.joplinbusinessjournal.com/about-us/">About us</a></li>
<li id="menu-item-6584" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6584"><a href="https://www.joplinbusinessjournal.com/contact-us/">Contact Us</a></li>
</ul></div> </div>
</nav>
</div>
</header>
<div class="site grid-container container hfeed" id="page">
<div class="site-content" id="content">
<div class="content-area" id="primary">
<main class="site-main" id="main">
<article id="post-7202" class="post-7202 post type-post status-publish format-standard has-post-thumbnail hentry category-gaming category-news">
<div class="inside-article">
<div class="featured-image page-header-image-single grid-container grid-parent">
<img width="1024" height="574" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20574'%3E%3C/svg%3E" class="attachment-full size-full wp-post-image" alt="Denver Nuggets and Bruce Brown agreed on a two-year contract" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315.jpg 1024w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-300x168.jpg 300w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-768x431.jpg 768w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-150x84.jpg 150w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315.jpg" /><noscript><img width="1024" height="574" src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315.jpg" class="attachment-full size-full wp-post-image" alt="Denver Nuggets and Bruce Brown agreed on a two-year contract"  srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315.jpg 1024w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-300x168.jpg 300w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-768x431.jpg 768w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-two-year-contract-e1656688538315-150x84.jpg 150w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript> </div>
<header class="entry-header" aria-label="Content">
<h1 class="entry-title">Denver Nuggets and free-agent wing Bruce Brown agreed on a two-year, $13 million contract &#8211; Joplin Business Journal</h1> <div class="entry-meta">
<span class="posted-on"><time class="entry-date published" datetime="2022-07-01T11:24:46-04:00">July 1, 2022</time></span> <span class="byline">by <span class="author vcard"><a class="url fn n" href="https://www.joplinbusinessjournal.com/author/abhishek_001/" title="View all posts by Abhishek Kumar" rel="author"><span class="author-name">Abhishek Kumar</span></a></span></span> </div>
</header>
<div class="entry-content">
<p>Bruce Brown has agreed for one of his career changing of two-year deal with the Denver Nuggets and the deal is worth an amount of more than $13 million, as per the latest sources and information spreading around media agencies on Friday.</p>
<p>The agreement includes a player option for the second year of the deal, sources told ESPN.</p>
<p>In the second-round pick in the year 2018, Brown was successful in bagged a unique role on the Brooklyn Nets the last two seasons as a versatile defender who played like a big man on offense despite his 6-foot-4 frame.</p>
<p>Brown, who will turn 26 years old in this year&#8217;s August 15, was being used primarily as one of their screener and rim-roller for a talented Nets team that did not require his ballhandling skills. The role helped Brown shoot over 50% from the field the last two seasons.</p>
<p>Brown improved as a 3-point shooter last season as well, hitting over 40% of his 3s on 1.3 attempts per game. He was one of Brooklyn&#8217;s best players in their first-round series loss to the Boston Celtics, averaging 14 points while shooting nearly 57% from the field and 42.9% from 3.</p>
<p><img class="alignnone size-full wp-image-7203" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%201024'%3E%3C/svg%3E" alt="Denver Nuggets and Bruce Brown agreed on a two-year contract" width="1024" height="1024" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164.jpg 1024w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-300x300.jpg 300w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-150x150.jpg 150w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-768x768.jpg 768w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-96x96.jpg 96w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="http://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164.jpg" /><noscript><img class="alignnone size-full wp-image-7203" src="http://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164.jpg" alt="Denver Nuggets and Bruce Brown agreed on a two-year contract" width="1024" height="1024" srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164.jpg 1024w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-300x300.jpg 300w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-150x150.jpg 150w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-768x768.jpg 768w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/07/Denver-Nuggets-and-Bruce-Brown-agreed-on-a-contract-e1656688521164-96x96.jpg 96w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></p>
<p>Brown became eligible for unrestricted free agency this summer after accepting his $4.7MM qualifying offer from Brooklyn a year ago. He spent his first two NBA seasons in Detroit from 2018-20 and has been a Net for the last two years.</p>
<p>Brown does a little bit of everything on the court, playing and guarding multiple positions while providing some scoring (9.0 PPG), play-making (2.1 APG), rebounding (4.8 RPG), and even three-point shooting (40.4%) in 2021/22.</p>
<p>Also Read: <a href="https://www.joplinbusinessjournal.com/2022/06/30/logan-paul-signs-superstar-contract-for-multiple-events-till-2023-with-wwe/">Logan Paul signs ‘superstar’ contract for multiple events till 2023 with WWE</a></p>
</div>
<footer class="entry-meta" aria-label="Entry meta">
<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://www.joplinbusinessjournal.com/category/gaming/" rel="category tag">Gaming</a>, <a href="https://www.joplinbusinessjournal.com/category/news/" rel="category tag">News</a></span> <nav id="nav-below" class="post-navigation" aria-label="Single Post">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev" title="Previous"><a href="https://www.joplinbusinessjournal.com/2022/06/30/sutta-chai-bar-haridwar-kulhad-of-love-now-available-in-haridwar-uttarakhand/" rel="prev">Sutta Chai Bar Haridwar &#8211; Kulhad of Love now available in Haridwar Uttarakhand</a></span></div> </nav>
</footer>
</div>
</article>
<div class="comments-area">
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/07/01/denver-nuggets-and-free-agent-wing-bruce-brown-agreed-on-a-two-year-13-million-contract-joplin-business-journal/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.joplinbusinessjournal.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7202' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c1b6168a8a" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="16" /><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
</main>
</div>
</div>
</div>
<div class="site-footer">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container">
<div class="inside-footer-widgets">
<div class="footer-widget-1">
<aside id="block-3" class="widget inner-padding widget_block"> <div class="web-stories-list aligncenter has-archive-link is-view-type-list is-style-default" data-id="1">
<div class="web-stories-list__inner-wrapper" style="">
<div class="web-stories-list__story">
<div class="web-stories-list__story-poster">
<a href="https://www.joplinbusinessjournal.com/web-stories/measure-safety-precautions-during-flood/">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20185%20308'%3E%3C/svg%3E" alt="Measure Safety Precautions to Follow if Flood Likely to Hit !!" width="185" height="308" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-150x200.jpg 150w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" loading="lazy" decoding="async" data-lazy-src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-640x853.jpg"><noscript><img
						src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-640x853.jpg"
						alt="Measure Safety Precautions to Follow if Flood Likely to Hit !!"
						width="185"
						height="308"
													srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-36789669572_c19397487b_b-150x200.jpg 150w"
																			sizes="(max-width: 640px) 100vw, 640px"
												loading="lazy"
						decoding="async"
					></noscript>
</a>
</div>
<div class="web-stories-list__story-content-overlay">
<div class="story-content-overlay__title">
Measure Safety Precautions to Follow if Flood Likely to Hit !! </div>
<div class="story-content-overlay__excerpt">
Keep the drainage system of your house clean and out of any blockage.
Unplug electrical gadgets and machinery and keep away from the reach of the water.
Store enough food and drinking water with you.
</div>
<div class="story-content-overlay__author">
By Avanish Jaiswal </div>
<time class="story-content-overlay__date">
On Jun 29, 2022 </time>
</div>
</div>
<div class="web-stories-list__story">
<div class="web-stories-list__story-poster">
<a href="https://www.joplinbusinessjournal.com/web-stories/top-10-water-fact/">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20185%20308'%3E%3C/svg%3E" alt="Why water going to covers about 73% of the earth&#8217;s surface." width="185" height="308" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability.png 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-225x300.png 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-150x200.png 150w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" loading="lazy" decoding="async" data-lazy-src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-640x853.png"><noscript><img
						src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-640x853.png"
						alt="Why water going to covers about 73% of the earth&#8217;s surface."
						width="185"
						height="308"
													srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability.png 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-225x300.png 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/06/cropped-MECO_WaterFacts_Sustainability-150x200.png 150w"
																			sizes="(max-width: 640px) 100vw, 640px"
												loading="lazy"
						decoding="async"
					></noscript>
</a>
</div>
<div class="web-stories-list__story-content-overlay">
<div class="story-content-overlay__title">
Why water going to covers about 73% of the earth&#8217;s surface. </div>
<div class="story-content-overlay__excerpt">
If the Earth Were a Globe 28 Inches in Diameter:
All of the water on the planet would fill less than one cup.
Only 0.03% of one cup is in rivers and fresh water lakes.
Slightly more than one drop of </div>
<div class="story-content-overlay__author">
By Avanish Jaiswal </div>
<time class="story-content-overlay__date">
On Jun 28, 2022 </time>
</div>
</div>
<div class="web-stories-list__story">
<div class="web-stories-list__story-poster">
<a href="https://www.joplinbusinessjournal.com/web-stories/kiara-advani-and-kartik-aryans-leaked-photos/">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20185%20308'%3E%3C/svg%3E" alt="Kiara Advani and Kartik Aryans Leaked Photos on Social Media" width="185" height="308" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-150x200.jpg 150w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" loading="lazy" decoding="async" data-lazy-src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-640x853.jpg"><noscript><img
						src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-640x853.jpg"
						alt="Kiara Advani and Kartik Aryans Leaked Photos on Social Media"
						width="185"
						height="308"
													srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-5b76b0b049468-e1653507776935-150x200.jpg 150w"
																			sizes="(max-width: 640px) 100vw, 640px"
												loading="lazy"
						decoding="async"
					></noscript>
</a>
</div>
<div class="web-stories-list__story-content-overlay">
<div class="story-content-overlay__title">
Kiara Advani and Kartik Aryans Leaked Photos on Social Media </div>
<div class="story-content-overlay__excerpt">
As per Sources, Kiara Advani-Sidharth Malhotra broke up after the release of Bhool Bhulaiyya 2. As Kartik Aryan and Kiara Advani started falling for each other during the sets of Bhool Bhulaiyaa 2. </div>
<div class="story-content-overlay__author">
By Avanish Jaiswal </div>
<time class="story-content-overlay__date">
On May 25, 2022 </time>
</div>
</div>
<div class="web-stories-list__story">
<div class="web-stories-list__story-poster">
<a href="https://www.joplinbusinessjournal.com/web-stories/best-pizza-in-kanpur/">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20185%20308'%3E%3C/svg%3E" alt="I ate 30 pizzas to find the best pizza in Kanpur" width="185" height="308" data-lazy-srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-150x200.jpg 150w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" loading="lazy" decoding="async" data-lazy-src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-640x853.jpg"><noscript><img
						src="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-640x853.jpg"
						alt="I ate 30 pizzas to find the best pizza in Kanpur"
						width="185"
						height="308"
													srcset="https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1.jpg 640w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-225x300.jpg 225w, https://www.joplinbusinessjournal.com/wp-content/uploads/2022/05/cropped-0W1A8543-1536x1024-1-150x200.jpg 150w"
																			sizes="(max-width: 640px) 100vw, 640px"
												loading="lazy"
						decoding="async"
					></noscript>
</a>
</div>
<div class="web-stories-list__story-content-overlay">
<div class="story-content-overlay__title">
I ate 30 pizzas to find the best pizza in Kanpur </div>
<div class="story-content-overlay__excerpt">
I Avanish Jaiswal visited more than 30 different café and restaurants in Kanpur But Best Pizza I found at Sutta Chai Bar, which is located in Saket Nagar area of Kanpur, Best Pizza I will give 10/10 </div>
<div class="story-content-overlay__author">
By Avanish Jaiswal </div>
<time class="story-content-overlay__date">
On May 22, 2022 </time>
</div>
</div>
<div class="web-stories-list__archive-link">
<a href="https://www.joplinbusinessjournal.com/web-stories/">
View all stories </a>
</div>
</div>
</div>
</aside> </div>
<div class="footer-widget-2">
</div>
<div class="footer-widget-3">
</div>
</div>
</div>
</div>
<footer class="site-info" aria-label="Site">
<div class="inside-site-info grid-container">
<div class="copyright-bar">
<span class="copyright">&copy; 2022 Joplin Business Journal</span> &bull; Built with <a href="https://generatepress.com">GeneratePress</a> </div>
</div>
</footer>
</div>
<script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script> <div class="web-stories-list__lightbox-wrapper ws-lightbox-1">
<div class="web-stories-list__lightbox">
<amp-story-player width="3.6" height="6" layout="responsive">
<script type="application/json">
					{"controls":[{"name":"close","position":"start"},{"name":"skip-next"}],"behavior":{"autoplay":false}}				</script>
<a href="https://www.joplinbusinessjournal.com/web-stories/measure-safety-precautions-during-flood/">Measure Safety Precautions to Follow if Flood Likely to Hit !!</a>
<a href="https://www.joplinbusinessjournal.com/web-stories/top-10-water-fact/">Why water going to covers about 73% of the earth&#8217;s surface.</a>
<a href="https://www.joplinbusinessjournal.com/web-stories/kiara-advani-and-kartik-aryans-leaked-photos/">Kiara Advani and Kartik Aryans Leaked Photos on Social Media</a>
<a href="https://www.joplinbusinessjournal.com/web-stories/best-pizza-in-kanpur/">I ate 30 pizzas to find the best pizza in Kanpur</a>
</amp-story-player>
</div>
</div>
<script type="rocketlazyloadscript" id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.joplinbusinessjournal.com","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script type="rocketlazyloadscript" id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<!--[if lte IE 11]>
<script src='https://www.joplinbusinessjournal.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.joplinbusinessjournal.com/wp-content/cache/min/1/amp-story-player-v0.js?ver=1656450512' id='standalone-amp-story-player-js' async></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/dist/dom-ready.min.js?ver=d996b53411d1533a84951212ab6ac4ff' id='wp-dom-ready-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/dist/hooks.min.js?ver=c6d64f2cb8f5c6bb49caca37f8828ce3' id='wp-hooks-js'></script>
<script type="rocketlazyloadscript" src='https://www.joplinbusinessjournal.com/wp-includes/js/dist/i18n.min.js?ver=ebee46757c6a411e38fd079a7ac71d94' id='wp-i18n-js'></script>
<script type="rocketlazyloadscript" id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.joplinbusinessjournal.com/wp-content/cache/min/1/wp-content/plugins/web-stories/assets/js/lightbox.js?ver=1656527831' id='lightbox-js' defer></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.joplinbusinessjournal.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
</body>
</html>
